A New Motherboard

After many years I bought a new motherboard for my office desktop. I built the current system in 2007. The original Asus M2NPV-VM motherboard died almost two years ago, which I replaced with an Asus M3N78-EM. I had an energy friendly 2.3 GHz dual core AMD BE-2400 in the M2NPV-VM and a 2.6 GHz AMD 5050e in the Asus M3N78-EM.

The new motherboard is an Asus Z170-K with a 2.7 GHz quad core i5-6400 CPU and 16 GB of RAM. The CPU has the Intel HD Graphics 530 integrated graphics. I did not want a bleeding edge motherboard, but something that would be a reasonably safe bet with Linux kernel module drivers and firmware. I'm not into overclocking or gaming.

The i5-6400 seems like an energy friendly CPU and will be faster than the AMD dual cores I had been running.

Not having purchased a new desktop motherboard in some time, I was unaware about power supply unit (PSU) requirements these days. The Z170-K uses a dual pin 12V header. My spare PSUs on the junk shelf are older models with a single 4-pin connector. I ordered a Seasonic S12II 430B rated at 430W. Likely the new PSU is overkill for my modest office usage. I ordered a 12V 4-pin to 8-pin header adapter, which I thought might be handy for future bench testing with the older PSUs.

All fan headers on the motherboard are 4-pin. My current 120 mm case fan is 3-pin. A 3-pin connector will work fine in a 4-pin header, but there is no pulse width modulation option. I ordered a single 4-pin case fan.

Another oversight was not remembering the DVD burner in the office desktop is an IDE. Oops, the Z170-K has no IDE connectors. I remembered I had a spare drive on the junk shelf, which turned out to be a SATA drive. Yes, I still use optical disks.

The reason the drive was sitting on the junk shelf is the device makes a gronking sound when powered on. That drive will have to suffice for a while, despite the annoying noise.

No floppy drive port either on the new motherboard. I have a multi-card device that has a built-in floppy drive. I don’t think I have used the floppy drive in several years.

I was anxious to bench test the new board and RAM to ensure I had no defects and return issues. I borrowed a PSU from work. After using a small screwdriver to jumper the power header pins, the motherboard came to life. Immediately I was pleased that the stock cooler fan was very quiet, even with no case. I had to get close to the motherboard to hear the fan. A silent or very quiet system is important to me.

I looked at the display monitor. I was momentarily mesmerized with the UEFI interface. I thought I was in a sci-fi episode or movie. Certainly these interfaces have changed dramatically since I last purchased a desktop motherboard. I could use a mouse as well as the keyboard to navigate.

I flashed the latest firmware, adjusted the time, and enabled virtualization support. I booted with a Slackware MATE Live ISO on a USB stick.

I selected the memtest86+ option. Oops. I received a “version too old for 32-bit” error message. I rebooted to the UEFI and enabled BIOS compatibility. I then could run the memory test. I let that run for about an hour. I could run the test longer but I figured a single pass was good enough.

After powering on the motherboard I noticed some slow flashing amber colored LEDs on the back of the motherboard. I was not concerned about being distracted because the motherboard would be in an enclosed Antec Solo II case underneath the desk. I was curious about the purpose of the LEDs. According to the user manual, these LEDs are called Audio Shielding (Breathing Mode) LEDs. Some kind of gaming feature. I have no idea whether I would need this feature as my audio demands on an office desktop are modest at best. I disabled the option in the UEFI.

I again booted with the Slackware MATE Live ISO. I ran glxgears as a simple GPU test. I connected a network cable and was able to run slackpkg update.

Next I booted with an Ubuntu MATE 16.04.03 ISO on a USB stick. The system booted with no desktop panels. I rebooted and added the nomodeset boot option. Why is this nonsense still needed these days? Otherwise the system seemed to run just fine.

A simple speaker test worked fine.

I received my new Seasonic PSU and repeated my tests. The new PSU is quiet. I connected my backup clone drive and ran some tests to shake down the new motherboard. After configuring the UEFI, wake-on-lan worked fine. The realtime clock worked too and would self awaken at the time I set in a script. I configured the system to wake-on-keyboard, using the space bar. VirtualBox worked fine. After tweaking the UEFI, hot swapping a SATA hard drive worked.

My SATA III disks were snappier than in the existing motherboard with SATA II ports limiting their full throughput. Having full throughput with the hard drive will be nice. These are mechanical disks and not SSDs.

In all, I was please except for one kink. There does not seem to be any support for the motherboard with lm-sensors and pwmconfig. The Asus Q-Fan feature seems to handle fans speeds on its own. As the fans run so quiet, I am guessing I will not miss that kind of control anyway. That said, a little digging revealed that I could obtain sensor information by adding the acpi_enforce_resources=lax boot option and ensuring the nct6775 kernel module is loaded. I decided I did not need to control fan speeds from the operating system but I would like the speeds shown in my conky display.

Next was to install everything into my existing Antec Solo II case.

I had decided to move the M3N78-EM to the LAN server. The server and office desktop are both housed in an Antec Solo II case. I decided to leave the office desktop as is and only move drives and devices.

The server changes bumped the server CPU to something a smidgen faster and increased the RAM from 4 to 8 GB. I will use the POS ASRock N68C-GS4 as a test system board. With the M3N78-EM motherboard I no longer will deal with compiling kernel modules to support wake-on-lan and no longer will I have to rescan devices when hot swapping backup drives.

In the former server case I pulled the generic PSU and AsRock motherboard. I installed the new shiny components.

The new PSU has the same form factor as the old PSU and installed nicely. The new Z170-K motherboard installed with little fanfare, although I struggled a bit with the connector backplane. Those tiny tabs seem to always frustrate me.

While the new motherboard uses UEFI, I had no desire to reformat and rebuild my Western Digital WD10EZEX Black SATA-III hard drive. Originally when I replaced the drive I partitioned with GPT rather than MBR. Adding an EFI partition is doable, but I saw no need. I would run the board using BIOS compatibility.

The multi-function card reader and TV capture card worked great.

With all components the M3N78-EM office desktop ran at about 55 watts idle. I connected the power cord of the new Z170-K office desktop to my Kill-A-Watt meter. The entire system idled at about 40 watts. Quite nice, considering I now had a more powerful CPU and twice the RAM.

Some nominal benchmarks indicate the new CPU is about 4 to 6 times faster. That's nice too. For me the noticeable improvement will be the integrated graphics and the additional two cores. I already have noticed an improvement running the basic desktop and virtual machines. While glxgears is not intended to be a benchmark test, the numbers offered me some kind of clue about the difference.

    vblank_mode=0 glxgears
      M2N78-EM (GeForce 8300):  504 fps /  2800 fps (output window minimized)
      Z170-K (Intel HD 530):   7937 fps / 12980 fps (output window minimized)
    CPU Blowfish (lower is better)
      M2N78-EM (AMD 5050e): 8.16
      Z170-K (i5-6400):     2.11
    CPU Cryptohash (higher is better)
      M2N78-EM (AMD 5050e): 112.63
      Z170-K (i5-6400):     716.63
    CPU Fibonacci (lower)
      M2N78-EM (AMD 5050e): 3.62
      Z170-K (i5-6400):     1.27
    CPU N-Queens (lower)
      M2N78-EM (AMD 5050e): 16.90
      Z170-K (i5-6400):      5.72
    FPU FFT (lower)
      M2N78-EM (AMD 5050e): 7.56
      Z170-K (i5-6400):     0.69
    FPU Raytracing (lower)
      M2N78-EM (AMD 5050e): 13.02
      Z170-K (i5-6400):      3.98
    hdparm -tT /dev/sda
      M2N78-EM (AMD 5050e):
        Timing cached reads: 1880 MB in 2.00 seconds = 940.06 MB/sec
        Timing buffered disk reads: 538 MB in 3.00 seconds = 179.30 MB/sec
      Z170-K (i5-6400):
        Timing cached reads: 28822 MB in 2.00 seconds = 14430.12 MB/sec
        Timing buffered disk reads: 528 MB in 3.01 seconds = 175.44 MB/sec

Often I had a difficult time using USB mice with the M3N78-EM. Although I have been running only a couple of days, I seem to no longer have that problem. I wonder if the USB voltage was low on the M3N78-EM. Thankfully I don’t often need a mouse with the server where the motherboard is installed.

I’ll need the next several weeks to notice anything else that needs tweaking.

For now I am pleased with the new arrangement.

Posted: Category: Usability Tagged: General

Next: Boot Splashes Redux

Previous: Another 20 GB Wasted